建站教学网,让你建站更便捷和轻松!
您当前的位置:首页 > 服务器 > linux教程

win10系统下安装superset的步骤

来源:建站教学网  时间:2020-01-27 19:34:56

superset是一个轻量级自助式BI框架,以优雅的界面和根据数据表动态生成数据为主要特点。

一、 环境

windows 10 64位 Python 3.7

二、 安装步骤

安装Python

建议安装Python 3.7 版本,Python官网:https://www.python.org/downloads/release/python-373/

下载64位Python下载 python-3.7.3-amd64.exe,直接使用exe的安装包即可,安装过程中选中增加到环境变量。

安装VS2015

Superset中依赖的一些库需要使用microsoft visual c++ 2010编译。

直接安装 Visual C++ 2015 Build Tools:http://xiazai.jb51.net/201912/yuanma/VisualBuild_Tools.rar

安装superset

先cmd进入dos界面

(1)pip install virtualenv

用virtualenv先在D盘建立工作目录,例如:D:/vir_env

在CMD输入下面的命令:

d:cd D:/vir_envvirtualenv env

激活环境:env/Scripts/activate

(2)根据python版本下载sasl,并安装。下载地址:http://www.lfd.uci.edu/~gohlke/pythonlibs/#sasl

选择合适的版本下载,例如现在安装的python 是3.7版本,系统是64位,就下载sasl-0.2.1-cp37-cp37m-win_amd64.whl。

这里一定要注意版本对上, 不然会安装不成功,报错(sasl.h 找不到),本文安装为3.7;

将其复制到D:/vir_env路径下执行命令

pip install sasl-0.2.1-cp37-cp37m-win_amd64.whl

(3)安装superset

pip install superset

可能遇到的问题1:

解决办法:

a. 在https://www.lfd.uci.edu/~gohlke/pythonlibs/ 中找到对应的包,py版本和系统版本要对上,下载到D:/vir_env目录下面

b. 安装对应whl文件

pip install 文件名

可能遇到的问题2:

error: could not create ‘build/bdist.win-amd64/wheel./superset/static/assets/dist/vendors-deckgl/layers/arc-deckgl/layers/geojson-deckgl/layers/grid-deckgl/layers/hex-deckgl/layers/p-39b91eb9.81565bc93ff56be4e334.chunk.js': No such file or directory ---------------------------------------- ERROR: Failed building wheel for superset

解决办法:

在Windows系统中启用长路径支持:

打开注册表编辑器:regedit

找到如下路径:HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Control/FileSytem

找到如下键值:LongPathsEnabled

将值修改为1:默认是0,不启用。

(4)创建管理员帐号

fabmanager create-admin --app superset

可能遇到的问题:报错Was unable to import superset Error: cannot import name ‘_maybe_box_datetimelike'

pandas 库版本太高导致的,需要安装低版本的 pandas 库。

解决办法:

a. pip uninstall pandas

b. pip install pandas==0.23.4

创建成功

(5)设置工作目录

cd D:/vir_env/env/Lib/site-packages/superset/bin

(6)初始化数据库

Python superset db upgrade

可能遇到的问题

InvalidRequestError: Can't determine which FROM clause to join from, there are multiple FROMS which can join to this entity. Try adding an explicit ON clause to help resolve the ambiguity. 报错.png

解决办法:

这是 SQLAlchemy 库版本太高导致的,需要安装低版本的 SQLAlchemy 库。

pip uninstall SQLAlchemypip install SQLAlchemy==1.3.5

之后重新运行

Python superset db upgrade

(7)加载测试例子

Python superset load_examples

可能遇到的问题1:

ConnectionRefusedError: [WinError 10061] 由于目标计算机积极拒绝,无法连接。

解决办法:打开网络与共享中心,点击Internet选项,在连接中选择局域网设置,将自动检测设置勾选上,然后确定;

可能遇到的问题2:

可能会因为网络状况影响而失败,切换网络多试几次就可以了

(8)初始化角色和权限

Python superset init

(9)启用服务

Python superset runserver -d

可能遇到的问题:

Error: No such command “runserver”.

解决办法:

使用以下命令启动:

Python superset run -p 8088

(10)打开http://localhost:8088,利用先前设置的用户名及密码登录即可;

总结

以上所述是小编给大家介绍的win10系统下安装superset的步骤,希望对大家有所帮助,如果大家有任何疑问请给我留言,小编会及时回复大家的。在此也非常感谢大家对脚本之家网站的支持!如果你觉得本文对你有帮助,欢迎转载,烦请注明出处,谢谢!

责任编辑:自由哥

免责声明:建站教学网内容来源于本网和互联网,如媒体、公司、企业或个人对该部分主张知识产权,请与本站联系,本网站将迅速采取适当措施,否则,与之有关的知识产权纠纷本网站不承担任何责任。
发表评论 共有条评论
用户名: 密码:
验证码: 匿名发表
精华推荐
CopyRight 2008-2019, JZREAD.COM, Inc. All Rights Reserved
皖ICP备07015033号